
GA2211 – Hard Surfaces Modeling Section A & B – Class Notes – Week 3 
 
Up until now, we’ve modeled in all the general detail we saw in our model. Some of the remaining small-scale detail can be better 
added in the material.  
 
Multi/Sub-Object Material: 
 
 The Multi/Sub-Object Material is a collection of multiple Materials/Shaders in one convenient group. This group makes a 
set of materials that complement each other more portable and cleans up the Material Editor – since you can edit all of them from one 
shader slot.  
 
 The most important aspect of the Multi/Sub-Object material is that Max uses it to allow multiple material assignments onto 
any one mesh.  Without the Multi/Sub-Object Material, you are limited with only 1 material per mesh. 
 
 
To Create a Multi/Sub-Object Material: 

Open the Material Editor. Hotkey to open the material editor is . 
 
Choose an empty slot – you can tell they are empty/un-assigned because they 
have no “dog ears”. 
 
The default material in these slots is the “Standard” material. 
 
1) To change to a Multi/Sub-Object material, click the button in the top-right (Currently set to “Standard”). 
 
2) A screen will pop up, with choices of Materials to choose from. Select “Multi/Sub-Object”. Hit OK. 
 
3) Notice that the details of the Material have changed. The Material is now a “Multi/Sub-Object” and the parameters have changed. 



 
Navigating the Material Editor – Multi/Sub-Object Material: 
 
4) This area of the Material Editor User Interface (UI) lets you set the number of 
Sub-Materials. You can enter a number and hit “Set Number” to set the total number 
of sub-materials in this Multi/Sub-Object Material.  
 
5) You can always add or remove materials in this list with these buttons. Click 
ADD or DELETE to add/delete a sub-material to the end of the list. 
 
6) This part of the UI lets you sort your materials, for convenience. You can sort by 
“ID”, “Name” or “Sub-Material” name/type. This only changes the order of the list, 
not the actual assignment or IDs. 
 
7) Each of these lines represents a Sub-Material. This area lets you quickly see the 
ID, Name and a color swatch of the material. 
 
8) To go DEEPER into any particular material, click on the button under the “Sub-
Material” column. This will navigate you deeper into that particular material. You’ll 
notice it looks just like the standard material you’re used to – it is, and has all the 
same settings and capabilities – but it is part of this group. 
 
9) Expand the “Maps” section of the material by clicking on the [ + ] next to 
“Maps”…you may have to scroll down to see it.  
 
10) These are your map-able channels. Anything that can have a texture map 
assigned will appear here. We’ll cover more of this later – for now, the important 
thing is to understand how to navigate the user interface. Click one of these buttons 
labeled “None” and select a bitmap as the type. You will see the menu has 
progressed one layer deeper. 
 
11) Any time you want to go back up a menu, click the “Go to Parent” button. This 
will send you back up one layer. You can continue to click the button to go up higher 
and higher – back to the main Multi/Sub-Object array menu. Once you are as high as 
you can go, the button will be grayed out.  
 

 



 Now, take some time to set up some materials. For our initial set, we need at least 3: Steel, Rubber, and Iron. Reduce the number of 
sub-materials to 3, as discussed earlier. 
 
For each of these materials, navigate through and make the changes below to each: 
 
12) You will want to name these materials. This gives a quick identification of which material you’re looking at. Click at the top-
center menu and type in a short, descriptive name. 
 
13) Adjust the Diffuse color. This is the base color of the material. Click inside the swatch to get a color picker, and choose a color 
value.  
 
14) In the Specular Highlights section, adjust Specular Level and Glossiness to achieve the desired shininess. As objects become 
more specular (Shiny), they reflect a tighter highlight (a CG convention meant to look like a reflection of the light source). You can 
use these numbers and the Specular (13) color swatch to adjust the levels. 
 
You will notice the Shader Ball in the material slot update to show you a preview of each of these changes. 
 
15) You will notice, upon navigating to the top of the Multi/Sub-Object material, that the list has updated to include a swatch of your 
material, the name we gave it, etc. This is a convenient place to look for the overall details of this Multi/Sub-Object material. 
 

 
 
Mesh Per-Polygon Material Assignment: 
 
Shader assignment of the Multi/Sub-Object material is just like any material. You can select the mesh in your viewport and click 
“Assign to Object” or drag the icon of the Shader Ball on top of your mesh in the viewport. 
 
The initial result may not be what you expected. This is because we have not told Max which Sub-Materials go where. This is done by 
setting polygon IDs.  
 
16) Go into polygon sub-object mode, and select all the polygons you wish to assign the first material – in my case “Steel”, because I 
have “Steel” as ID #1. 
 
17) At the bottom of the Modify panel, just above Smooth Groups, there is a section Polygons: Material IDs. In the “Set ID” box, 
type the ID for that material…in my case 1. You can also use the buttons next to this box to go up or down an ID. Your selected 
polygons should have taken on the exact sub-Material you selected. You may need to de-select your polygons or go to the “top-level” 
to see the results more clearly. 
 



 
 
Do this for the remainder of your materials and meshes. Select polygons, then “Set ID” to the ID associated with the Sub-Material 
you want assigned to that polygon. 
 
You should now have basic shaders assigned: 
 
 
 
 



BUMP Mapping, Hardware Render Preview & UVW Map Modifier: 
 
 In our reference material, we see that some fine detail is etched into the metal. Also, we notice dome-like bumps on the 
rubber handle to add grip. While these details can be modeled, it is often more effective to add these details into the material. We’ll 
cover some techniques to apply some of these details. 
 
BUMP Map/Height Map: 
  
 A Bump Map, now commonly referred to as a Height Map due to the 
introduction of other similar mapping techniques, is a Black and White (gray scale) 
image that encodes height data as tones of gray. White pixels come up in height, and 
black pixels receded into the depth of the polygon – with values of gray in between. The 
final result is throttled by a “Bump” setting in the material, which produces an embossed 
effect that simulates relief in the geometry.  
 
[ Note: ]  No actual geometry is changed, and this effect breaks down when the silhouette 
is unchanged…but for simple etched relief, it is very effective. 
 
 Creating a Bump/Height Map: 
 
 There are many ways to create a quality bump map/height. This is a skill in 
itself, and many studios have dedicated texture artist’s whose sole job is to create maps 
and texture finished models. This is a brief introduction into some of the process. 
 
Logo Etching: For simple etched text and logos, such as the Smith & Wesson logo above, you can probably get high quality 
samples from the company themselves. Look at the company website, avid fan sites and clubs, or simply do a Google image search. 
 
Because of compression for the Internet, there may be noise in your image. This one shows some pretty obvious JPEG compression 
noise.  
 

 
 



Using Photoshop, take out the noise until you have a clean Black and White image…there should be no other values except absolute 
black and absolute white (in this case). Successive “Brightness & Contrast” adjustments and color fills(paint bucket) should result in a 
clean image. 
 
To turn a solid shape into an outline, I like to use the “Stroke” Layer  Style. To do this: 
 
 Use “Select > Color Range” to select the black shapes.  
 
 You can leave the Fuzziness pretty low, as our image was pre-processed 
above to give a good contrast. Hit “OK” to create this selection. 
 
 You can, alternately, use the magic wand to select each shape individually. 
 
 Create a new layer. 
 
 With the selection still active, fill in ALL WHITE in this new layer. 
 
 Go to “Layer > Layer Style > Stroke”. 
 
 Select BLACK as the stroke color.  
 
 Select the desired thickness in pixels. Use the preview as a guide. 
  
 
 Create another NEW Layer. Place this under the one we just made, the one 
with the stroke outline. 
 
 Fill in ALL WHITE in this new layer to create a white background. 
 
 Your image should be a clean outline of the shapes we started with. 
 

 The next step is to CROP in a clean square. Hit  +  
while in the Marquee tool (selection) to drag out a perfect square. 
 
 Choose “Image > Crop” to crop the image. 
 
 Scale the image down, or increase the CANVAS SIZE uniformly to give 
yourself some room around your image – you will need this later for placement. 
 
 Final image should look like this (minus the red border): 
   
 
 Resize the image as a “Power of Two” multiple. This means that the height and 
width (in pixels) should be a multiple of 2 to the power of two. In practice, this means 
images with dimensions of 128x128, 256x256, 512x512,1024x1024,2048x2048, etc…
  
 32/64 bit computers are more efficient at processing images in these sizes, and it 
will speed up renders to use power of two sized images. Additionally, Game Engines 
mostly require it for efficiency…so get used to working in powers of two. 
 
 Save the image in a format Max can read – this is usually TIFF, TARGA, BMP, JPEG…TIFF and TARGA are desired, 
because of the options for compression and Alpha Channels (Transparency). 
 
  



Assigning a Bump Map: 
 
 Now that you have a bump/height map, let’s apply it to our model. 
 
 Because this is a localized detail, we don’t want the bump map applied to the whole model. We only want this bump map 
applied to the STEEL areas – and in fact, we only want to apply it to a single portion of the STEEL, just above the grip on the left side. 
 
 We’re going to have to create a new material, based on the STEEL Sub-Material, for use in this detail region. This will leave 
us with two nearly identical materials; one that has no Bump map, and another that has this new Bump map inside it.  
 
18) Go back to your Multi/Sub-Object Material. You should currently only have 3 materials. You will need to ADD another. Click the 
“Add” button to add a fourth material. 
 
19)  You’ll notice a new default material has been added to this Multi/Sub-Object, and it has been given the ID 4. To make a copy of 
the STEEL material and replace ID 4, drag from the button labeled “STEEL” onto the new material. A screen will ask if you want to 
instance or Copy the material – we want a unique copy. 
 
20) You’ll now see a unique copy of STEEL material. Please rename this (as explained above) so that you don’t confuse the two. 
 

 
 
Assignment is as simple as selecting the polygons you wish to have this material and setting their Material ID to 4 (see above how 
to set material IDs). 
 
In this new copy of “STEEL”…call it “STEEL_Logo”…we want to map the “BUMP” channel. See # 10 above for where to assign the 
bump channel. 
 
Once assigned, the Shader Ball preview will show a preview of your Bump Map on the material. Use this 
to tune the results. 
 
You can increase/decrease the relief by setting the value next to “Bump” under the “[+] Maps” section of 
the STEEL_Logo material. 
 

 



Placement and Preview of Bump Map: 
 
 Once you have your Bump Mapped Material set up, it’s time to place and preview the Bump Mapped Logo. 
 
 
UVW Map Modifier: 
 
 To be able to place the Logo in the portions of the model we want – we’ll need to do some conversion from 2D image onto 
3D model. This process of covering a 3D model with 2D images is called UV mapping, or “UV-ing”. We’re not going to get into the 
full details of this yet, as this is another area that deserves a full explanation – but it is enough now to understand that, behind the 
scenes, a translation is made from 2D image onto 3D space.  
 
 A simple method of UVing is to use the UVW 
Map Modifier. This Modifier lets you make simple 
projections onto your model, and we will use the PLANAR 
method to project our image. 
 
To use the UVW Map Modifier: 
 
21) In Sub-Object Polygon mode, select the polygons that 
have the STEEL_Logo material assigned…these should be 
just above the grip on the lefts side of the pistol. 
 
22) In the modify panel, just above the stack, select the 
drop-menu “Modifier List”…scroll down to UVW Map. 
 
Great, so now we have UV mapping…but we can’t see the 
result! There are two ways to see the result of bump 
mapping: 
 

 Full Software Render – You can hit the 
RENDER button in the main toolbar (the Teapot) 

 to get a quick render. 
 

 Hardware Preview – This method will use your 
VIDEO CARD GPU to do a Hardware Render 
LIVE in your viewport. Many features once only 
available in Software rendering are becoming 
available because of advancements in GPUs. Bump 
mapping is supported in Hardware Rendering. 

 
Set up Hardware Rendering in Viewport: 
 
To see a Hardware preview of your Bump Map, you need to 
turn this feature on. Go to : 
 
Views > Show Materials in Viewport As > Hardware 
Display with Maps. 
 
After a brief buffering period, the viewport will change to 
show a preview of your 
mapping.  
 
 
This is heavily dependent on 
the capabilities of your 
video card.  
 
 



The UVW Map modifier has some settings you should be aware of: 
 
23) You can adjust the height and width of 
your projection here. Since our image was 
a square aspect ratio, it is advisable to set 
the height and width exactly the same – to 
avoid distortion. 
 
24) You’ll notice in the Stack we have the 
UVW Map Modifier. If you click on the 
[ + ] next to it, you can go into sub-object 
mode with this Modifier. The only 
available Sub-Object is GIZMO. Selecting 
GIZMO here lets you move, rotate and 
scale the planar projection to adjust the fit. 
 
25) You’ll notice, with GIZMO selected, 
you have the standard GIZMO shown with 
move/rotate/scale possible. 
 
Adjust the fit of your Logo. When 
complete, right-click and select “Collapse 
All” to collapse the stack back to simple 
Editable Poly. 
 
Repeat the above steps to create further bump maps, new materials and Material ID selections to add further detail to the gun. 
 

  


